Resistor-color, problème avec un exo JS sur Exercism.io
1 month ago par Christophe Le Vosgien

  • 2

    Salut

    J'ai un problème avec l'exercice "Resistor Colors", quand je lance le test avec npm test pour vérifier que mon tableau COLORS correspond bien à ce qui est expected il me renvoie cette erreur :

    (lien si image non fonctionelle : https://media.discordapp.net/attachments/557855152816783360/566612956213805066/unknown.png )

    Voici le code des specs :

    import { colorCode, COLORS } from './resistor-color'
    
    describe('ResistorColor', () => {
      describe('Color codes', () => {
        xtest('Black', () => {
          expect(colorCode("black")).toEqual(0)
        })
    
        xtest('White', () => {
          expect(colorCode("white")).toEqual(9)
        })
    
        xtest('Orange', () => {
          expect(colorCode("orange")).toEqual(3)
        })
      })
    
      test('Colors', () => {
        expect(COLORS).toEqual(["black", "brown", "red", "orange", "yellow", "green", "blue", "violet", "grey", "white"])
      })
    })

    Et voici le code de resistor-color.js

    export const COLORS = [
        "black",
        "brown",
        "red",
        "orange",
        "yellow",
        "green",
        "blue",
        "violet",
        "grey",
        "white"
    ];
    
    export const colorCode = (color) => {
        return COLORS.findIndex((input) => { input == color });
    };

    Merci =)


    VSCode - Comment utiliser les opérateurs (>+* etc..) avec des snippets personnalisés ?
    1 month ago par Christophe Le Vosgien

  • 0

    Hello

    J'ai créé des user snippets pour CSS et j'aimerais utiliser de la même façon qu'en HTML, l'opérateur de multiplication notamment.

    Par exemple voici un snippet de base que j'ai créé :

    "Fast class definition": {
        "prefix": ".",
        "body": [
            ".$1 {",
            "\t$2",
            "}",
            "$0"
        ],
        "description": "Set a basic class definition with the name to fill in"
        }

    Et j'aimerais pouvoir faire par exemple : .*3 et que ça me sorte le code :

    . {
    
    }
    . {
    
    }
    . {
    
    }

    Une idée peut-être ? Désolé de vous ennuyer avec mes problèmes de snippets, mais je m'efforce de respecter l'adage qui dit qu'un bon développeur est un développeur fainéant :) :) :)

    Merci !


    Mise en forme d'un tableau bootstrap
    5 months ago par Kevin

  • 0

    Comment resize une colonne dans un tableau. Merci bien.


    Séparation entre le texte et la flèche dans un menu bootstrap
    5 months ago par Stef

  • 0

    Comment fait on pour sépararer le texte et la flèche dans un menu ou un bouton bootstrap? Par exemple pour avoir le texte aligné à gauche et l'icône alignée à droite.

    Merci!


    Mettre du style en inline dans un fichier blade (Laravel)
    6 months ago par Stef

  • 0

    @if(session('error'))

    {{ session('error') }}

    @endif

    J'ai essayé de colorer mon message d'erreur en rouge mais cela ne fonctionne pas. Comment faire?

    Merci


    Problème accès profile
    6 months ago par Arnaud63

  • 0

    Quand l'utilisateur est connecté on souhaite accéder à son profil via son id mais nous avons cette erreur :

    Notice: Undefined variable: candidat

    l'erreur viens de là : $query = 'SELECT * FROM candidat WHERE id = "'.$candidat->getId().'"';

                Avez-vous des solutions ?

    Routing sur Laravel sous Laragon
    7 months ago par LoicNeyron

  • 0

    J'ai un gros soucis, quand je veux créer une route pour amener a une vue, je fais : Route::get('/JobOffers', function () { return view('jobOffers'); }); et ma vue s'apelle bien : "jobsOffers.blade.php" j'ai mis sa comme lien : Jobs Offers quand je clique sur le lien qui est censé m'amener sur cette vue l'url ressemble a ça :http://localhost/JobOffers même avec ça : Jobs Offers j'ai : http://localhost/projet-luxury-services/public/public/JobOffers j'ai toujours et partout : error 404 Not Found / nginx/1.14.0

    Help Me Please !